Users will be experiencing problems working with videos.

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Mar 22, 2025 - 11:41 AEDT

Identified

Users may experience difficulties working with videos. Our team is actively investigating the issue. Thank you for your patience and understanding.
Posted Mar 22, 2025 - 06:14 AEDT