Some users are unable to see the "Download" button
Incident Report for Canva
Resolved
- This incident is now resolved. Thank you for your patience and understanding.
Posted Nov 28, 2024 - 18:35 AEDT
Investigating
We have been aware that some users might not see the "Download" button from their end.
Posted Nov 28, 2024 - 17:48 AEDT