Unable to upload images

Incident Report for Canva

Resolved

The issue affecting image uploads on Canva has been resolved.
Posted Feb 25, 2025 - 17:19 AEDT

Update

We are aware of an issue where users are unable to upload images and are currently investigating.
Posted Feb 25, 2025 - 15:54 AEDT

Investigating

We are aware of an issue where users are unable images and are currently investigating.
Posted Feb 25, 2025 - 15:51 AEDT