Ongoing Issues with PayPal Payments

Incident Report for Canva

Resolved

This issue has now been resolved. If you continue to experience any errors, please try refreshing your page.
Posted Feb 25, 2025 - 18:43 AEDT

Investigating

We’re aware of issues affecting PayPal payments, as well as publishing designs with premium elements — including for Canva Pro and Teams users subscribed via PayPal, even when no payment is required. Our team is actively working on a fix and will share updates as soon as possible. Thank you for your patience.
Posted Feb 25, 2025 - 16:16 AEDT
This incident affected: Downloading designs and Billing and subscriptions.