Canva Homepage Inaccessible
Incident Report for Canva
Resolved
This incident is now resolved. Thank you for your patience and understanding.
Posted Mar 22, 2024 - 01:58 AEDT
Monitoring
Issue has been identified and we are monitoring the fix.
Posted Mar 22, 2024 - 01:36 AEDT
Investigating
Investigating the issue
Posted Mar 22, 2024 - 01:21 AEDT
This incident affected: Home page.